What are the System Requirements?

← Back to FAQ

Each version of Touch Bible has its own file size and other requirements to run. See the App description on the store for more details. Touch Bible will run on iPhonei, iPod Touchi, iPadi, and most Android Devicesii.

iTouch Bible Requires the iPhone OS update 2.2.1 up to iOS 8 and later, with age restrictions turned off for ages 12 or higher.

iiTouch Bible™ Requires Android OS 1.5 or higher and 20MB (Max) of free space (phone memory, not SDCard memory). Some Android devices have more memory and faster procesors than others, so the experience may vary between phones. Some devices may not have enough resources to run Touch Bible.